Hulpartikel overzicht

Hulpartikel

Ik wil op webhosting scripts gebruiken

In principe kan je alle scripts gebruiken die geschikt zijn voor Unix-systemen met PHP. Er zijn echter wel beperkingen: de scripts mogen niet te veel processorkracht innemen. Je maakt immers gebruik van een gedeelde server en andere klanten mogen geen last hebben van je toepassing. Daarnaast is het verboden om scripts te gebruiken die onveilig zijn en die gebruikt kunnen worden door hackers en spammers.

Een aantal scripts die erom bekend staan onveilig te zijn en die onmiddellijk tot deactivatie kunnen leiden bij constatering, is hieronder weergegeven. Dit is echter GEEN volledige lijst.

Je dient van elk script dat je gebruikt, zorgvuldig na te gaan of je script voldoende bescherming biedt tegen hacking, spamming en overmatig CPU-gebruik. Ook dien je er op te letten dat je je script blijft updaten, omdat er bijna dagelijks nieuwe hacks op het internet verschijnen. Daardoor blijkt je veilige script ineens onveilig te zijn.

Lijst van enkele verboden scripts, die direct tot deactivatie kunnen leiden:

  • Torrent trackers
  • Criminals / war games
  • Topsite scripts
  • ownCloud
  • Ikonboard
  • UltimateBB / UBB
  • YaBB forum
  • PHPNuke
  • lstmrge.cgi
  • JUMultithumb
  • Matt's FormMail
  • DT_formmail (zeer onveilig PHP formmail script)
  • Alle proxy scripts zoals PHPproxy en Anonymizer
  • Alle chatrooms en chatscripts, en scripts gerelateerd aan IRC
  • Alle scripts die een shell-prompt geven of servercommando's uitvoeren mogelijk maakt
  • Zen Cart
  • Zogeheten Habbo 'retro's'

Heb je ook een goed idee?

Stuur jouw idee in! Met genoeg stemmen komt jouw idee op onze wishlist!

Heeft dit artikel je geholpen?

Maak een account aan of log in om een beoordeling achter te laten.

Reacties

Maak een account aan of log in om een reactie te plaatsen.

Kom je er niet uit?

Ontvang persoonlijke hulp van onze supporters

Neem contact op