Hulpartikel overzicht

Hulpartikel

Plesk: Ik wil de PHP-versie updaten

Plesk update zichzelf automatisch en komt met recente PHP-versies geïnstalleerd. Mocht je automatische updates uitgeschakeld hebben staan, is het uiteraard ook mogelijk om PHP handmatig te updaten. In deze handleiding laten we zien hoe dit werkt.

De huidige versie van PHP kun je altijd controleren via command-line met het commando:

ls /opt/plesk/php/

Om veiligheidsredenen raden we af om verouderde PHP-versies te gebruiken.


 

Stap 1

Log in op Plesk, ga naar 'Tools & Settings' en klik op 'Updates'.

plesk tools and settings plesk updates


 

Stap 2

Je komt nu op de 'Add components'-pagina terecht.

Klap 'Web Hosting' > 'PHP interpreter versions' uit en verander het kruisje naar een vinkje bij de versies die je wil installeren. Klik tot slot op 'Continue' om de software te installeren.

plesk add components php

Als je nu onder 'Websites & Domains' naar jouw website gaat, zie je onder 'PHP Settings' de huidige PHP-versie van dit domein terug en kun je deze aanpassen.


 

Mocht je aan de hand van deze handleiding nog vragen hebben, aarzel dan niet om onze supportafdeling te benaderen. Je kunt hen bereiken via de knop 'Neem contact op' onderaan deze pagina.

Wil je dit artikel met andere gebruikers bespreken, laat dan vooral een bericht achter onder 'Reacties'.

Probeer BladeVPS een maand gratis

Maak van jouw volgende website of applicatie een succes op BladeVPS PureSSD. Probeer direct of een self-managed VPS iets voor jou is; de eerste maand krijg je van ons :-)!

Start nu je gratis maand

Heb je ook een goed idee?

Stuur jouw idee in! Met genoeg stemmen komt jouw idee op onze wishlist!

Heeft dit artikel je geholpen?

Maak een account aan of log in om een beoordeling achter te laten.

Reacties

Maak een account aan of log in om een reactie te plaatsen.

0
Matthijs van Beek Admin 21 augustus 2020 (#4688)

@killerog,

Bedankt voor je feedback! We zullen dit artikel in de toekomst updaten op een manier waarop je niet de command-line in hoeft te duiken.

0
killerog 11 april 2020 (#4299)

Het php -v commando werkt standaard niet op voorgeïnstalleerde versie.

Je zult standaard het /opt/plesk/php/7.3/bin/php als commando moeten gebruiken. Wel jammer, ik dacht dat bij een server met plesk dit standaard goed zou staan. Ik ben niet zo technisch dus ga hier liever niet aan rommelen als het niet echt hoeft.

Kom je er niet uit?

Ontvang persoonlijke hulp van onze supporters

Neem contact op