/ Kwetsbaarheid in GraphicsMagick & ImageMagick

Datum:

Gisteravond is er een kwetsbaarheid ontdekt in GraphicsMagick en ImageMagick. Dit is veelgebruikte software voor het verwerken van afbeeldingen. Deze bug maakt het onder bepaalde omstandigheden mogelijk om op afstand code uit te voeren op de onderliggende server. Direct na de ontdekking hebben wij onze systemen gepatched.

Gezien de ernst en de aard van deze remote-exploit willen we gebruikers van GraphicsMagick of ImageMagick adviseren om onmiddellijk actie te ondernemen. Dit door deze software uit te schakelen of andere mitigerende maatregelen te nemen. Let op, het uitschakelen van deze software kan er voor zorgen dat bepaalde functies op je website of applicatie niet meer werken.

Uiteraard houden we je op deze pagina op de hoogte van de ontwikkelingen.

Update: Nieuwe security patches beschikbaar

Er zijn inmiddels security patches uitgebracht voor verschillende bij ons beschikbare distributies. Hieronder lees je hoe je jouw distributie kunt patchen:

Debian / Ubuntu

   sudo apt-get update && sudo apt-get upgrade

Gentoo

  emerge --sync

  emerge --update imagemagick graphicsmagick